
Transparency in Adobe  
Applications -New Highlights

Improvements in the Flattener
Newer technology has minimized the problems relating to printing and 
the handling of transparency, such as undesired color conversions,  
rasterization of elements, artifacts, slow print and processing times.

Adobe PDF Print Engine
Enabling technology from 3rd party vendors, is based on the PDF/X4 
standard, which supports transparent artwork and effects, as well as  
layers (not based in postscript). When creating PDF files for print produc-
tion-especially if the RIP or workflow system is based on the Adobe Print 
Engine you should choose PDF/X4 as your file format for best results.

Postscript Level 3 RIPs
With built in support for PDF 1.4 specification can print transparency 
without requiring additional changes. Postscript level 2 and older RIPs 
which don’t support transparency require adjusting transparent objects 
in order to print.
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Flattened Transparency

EPS

DCS

JPEG

GIF

BMP

Photoshop 6 TIFF 

Postscript

 All PDFs from Distiller

PDF 1.3 (Acrobat 4)

Live Transparency- 
can be edited

Photoshop (.psd), layered TIFF, 
Photoshop PDF

Native Illustrator 9-10, CS, CS2, 
CS3 (.ai); PDF 1.4 above

Native InDesign files-2, CS,  
CS2, CS3 (.indd)

PDF 1.4, 1.5, 1.6, 1.7  
(Acrobat 5-8) (.pdf) 

Live vs. Flattened  
Transparency



The process of flattening converts 
all of the overlapping and intersect-
ing elements in a group of  
transparent objects into a collection 
of opaque elements that appear the 
same as the original. Flattening cuts 
apart transparent areas to represent 
overlapping areas as discrete pieces 
that are either vector objects or  
rasterized areas.

Transparency and Flattening



•	Any object that is a source of transparency or interacts 
with transparency will require flattening
•	Sources of Transparency

• Opacity of less than 100%	 • 	Blend mode other than normal
•	Opacity Mask-Illustrator	 •	 Drop shadow or feather 
• 	Inner/Outer Glow Effects-Illustrator	 •	 Effects-InDesign
• 	Fill or stroke has a style, brush, pattern or filter effect that have any of the 

previous properties
• 	Placed PSD file (native, PDF or Tiff) with transparent background
• 	Placed AI file (native or PDF) that contain one or more of the objects above

•	Objects Interact with Transparency if:
•	Source of Transparency
• Overlapped by a source of transparency
•	 Is very close (usually within 1 point) of a source of transparency and  

beneath it in stacking order (including objects on other layers)

Determining if an Object will 
be Flattened



Controlling the Flattener
•	Needed when printing or exporting from Illustrator, InDesign or Acrobat*.
•	Controls whether objects are rasterized or remain in vector form.
• 	If objects are rasterized, their resolution.
• 	How type and strokes are processed and whether they are converted to  

outlines.
• 	Whether complex regions are clipped using clipping paths around parts of 

the transparent design.
• How overprinting and spot colors are handled (Illustrator)
•	 Invoked During Export to PostScript-based Format
	 EPS (Encapsulated PostScript)
	 File > Print
	 Acrobat 4.0 (PDF 1.3: this includes PDF/X-1a) and distilled PDF
•	Ignored in Export to Acrobat 5.0 (PDF 1.4) or Above
	 Acrobat 5.0 and above supports live, unflattened transparency as well as 

PDFX/4



Flattener Settings and Styles

• Flattener Styles-used in InDesign 2-CS3, Illustrator CS-CS3 
and Acrobat 8 Professional
• 	Low Resolution Setting, on-screen proofing
•	Medium Resolution Setting, desktop printing, up to 300 dpi; Default  

settings in all applications, not sufficient for commercial printing or high 
resolution devices.

•	High Resolution Setting, printing press or 1200 dpi setting.
•	Recommended custom flattener settings- 

Raster/Vector Balance Slider-determines how hard the flattener works to keep objects 
in their vector form in the flattened output. All the way to 100 recommended.

	 Line art resolution-Rasterized Text and Vector Art. Should be the same as device  
resolution: e.g., 2400 ppi but can cut processing time by using 1/2 of final resolution

	 Gradient mesh resolution-Generated Shadows and Feathering. Should be the same as 
general image resolution: e.g., 300 ppi, not larger than 300 ppi

	 Leave clip complex paths selected to minimize stitching.
	 Convert Text to Outlines/Strokes to Outlines
• 	Transparency Blend Space: Document Color Space (usually CMYK)

 



Flattener Previews

•	Useful to check for rasterized 
text and vectors
•	Useful as a guide for fixing files
•	Available in:
	 Illustrator CS1/CS2/CS3
	 InDesign CS1/CS2/CS3
	 Acrobat 6, 7, 8 Professional



•	Available in Illustrator, InDesign and Acrobat.
•	In addition to applying blending modes to 
overlapping objects, you can overprint objects 
that are in front of other objects. In InDesign you can  
select from attributes palette or when setting up colors to 
have them overprint. Overprint black default setting in  
InDesign.
•	In order to correctly view many blend modes you need to 

preview in Overprint Preview. Always check your files in 
Overprint preview if you have used transparency effects in 
Illustrator, InDesign and Acrobat.
•	Reader 7 and 8 have preferences to turn on Overprint  

Preview

Overprint Preview



Illustrator Shadows

Filter Effect

Spot 
Color

•	Filter>Stylize>Drop Shadow 
creates and embeds an image

•	Effect>Stylize>Drop Shadow is 
a live effect: it can be changed

•	Resolution of shadows: 
Effect>Document Raster  
Effects Settings

•	Illustrator Effect shadows  
behave correctly in InDesign

•	Can apply spot color to drop 
shadows in Illustrator, see  
separation preview



Illustrator Settings

•	Additional Document Raster Effects Setting-setting  
determines the resolution to all Illustrator raster  
effects, including drop shadows and feathered edges. 
Effect>Document Raster Effects Settings.
•	Can flatten individual objects in Illustrator-Object>Flatten 

Transparency
•	Preserve Overprints and Spot Colors-unique to Illustrator
•	New document presets in Illustrator CS3-Creating new 

print document automatically sets the raster resolution of 
300 ppi and CMYK print mode



•	Illustrator
	 Be sure that if you are exporting Illustrator files as PDF (below Acrobat 5 or 

PDF 1.3) or saving as EPS to be placed into other page layout software or 
printed from those formats that you set the transparency flattener to a setting 
compatible for expected output. High resolution for print or ask your service 
provider for their settings. 

•	InDesign
	 Be sure that if you are exporting from InDesign to PDF (below Acrobat  5 or 

PDF 1.3), eps or printing to postscript formats that you set the transparency 
flattener to a setting compatible for expected output. High resolution for 
print or ask your service provider for their settings.

•	PDF
	 Be sure that if you are providing an exported PDF (below Acrobat 5 or PDF 

1.3) for commercial printing that you set the transparency flattener to a set-
ting compatible for expected output. High resolution for print or ask your 
service provider for their settings. Note: Adobe PDF 1.4, PDF 1.5, PDF 1.6 and 
1.7 files created using Distiller do not contain live transparency because Dis-
tiller operates on PostScript, which can only contain flattened transparency.

Exporting Files



•	Print proofs before final output
•	Proof with Overprint Preview turned on, during screen 

proofing
•	Ensure you have looked at your file with the transparency 

flattener preview.

Proofing Files



Additional Notes

Shadow Over Spot Color
If you see a white box, representing the entire frame of where the shadow 
should be then ensure that postscript printing is turned on in the RIP and/
or contact your vendor for a patch.
Also double check the file with overprint preview turned on or ensure you 
have exported to Acrobat 5 or above.



Stacking Order
Move objects to the top/front of the stacking order 
if they do not have transparency effects applied or 
place on the top layer. Keep text on the top most 
layer or stacking order for faster print times and to 
minimize rasterization.

Avoid Mixing Color Spaces
Make sure you have the correct  Transparency Blend Space selected, 
CMYK for Print and RGB for Web.

Try not to mix RGB and CMYK files inside the applications when using 
transparency.

Opacity vs. Tint Percentages
Use tint percentages 50% tint versus opacity slider to lighten.

Designer’s Best Practices



Use native file formats to keep transparencies live and editable.
Photoshop Illustrator InDesign

.PSD & .PDF .AI & .PDF .INDD

•	Import Native File formats into InDesign when possible. 
Greater control at print time, flattening at last stage 
•	Use the best tool for each job
	 • Photoshop – bitmap image editing
	 • Illustrator – vector-based artwork
	 • InDesign – page assembly 
•	Reduce your file load and save disk space
•	Change your mind whenever you want

Importing Files Into InDesign



Best Practices for Designers

Drop Shadows 
Don’t set the Blur value to 0. If you do, the shadow will be hard-edged in-
stead of soft, and the edge of the shadow will be bitmapped/jagged.

Blend Modes
Be sure to view blend modes under overprint preview to ensure they  
produce desired results.

•	Make sure your printer and you are using the latest versions 
of Adobe software (CS3).

•	Good communication with your printer is key.
•	Ask your printer for their flattener styles or pdf styles.
•	Send your printer some test files if using complex  

transparency.



Text, Typography, and Transparency
Avoid using type that’s too small or too fine when applying  
transparency effects.

Spot Colors and Transparency
Avoid using the Difference, Exclusion, Saturation, Luminosity, Color,  
and Hue Blend Modes with Spot Colors.
Be sure to preview transparency used with spot colors and blend modes 
in overprint preview mode to verify desired results.
To minimize problems relating to spot colors, delete all unused spot  
colors before you export or print.

OPI Workflow
Must have high resolution images to work properly with transparency-
fatten before you flatten.

Best Practices for Designers



Best Practices for Printers

•	Must have Postscript 3015+ in the RIP
•	Turn ON “PostScript Overprint” on the RIP. Transparency Flatten-

ing exploits this PostScript operator. You should never use a RIP’s 
“discard overprint” option when dealing with transparency.

•	Get Current Vendor Patches for Your RIP
•	Create a Flattener Preset Suitable for Your RIP
•	Preflighting for Transparency
	 Check for Stacking Order—Put Text on Top
	 Check for and fix RGB content
	 Check for spot converted to process
	 View file with Overprint Preview Turned on
	 View with Flattener Preview to See if need custom  

flattener style to resolve rasterization
•	Adobe PDF Print Engine



Best Practices for Printers

•	Don’t Put Unflattened PDF’s (Acrobat 5.0+) into QuarkXPress
	 Incorrect processing may result in incorrect output
•	Carefully use EPS final output or placing into other software. 

Some prepress software may inadvertently misinterpret  
flattened EPS files, which results in converting spot colors to 
process. In this case, do not use EPS; use native InDesign CS3, 
native Illustrator CS3, or Adobe PDF files that include live  
transparency.

•	Transparency and OPI
	 Open Prepress Interface (OPI) is not compatible with  

transparency. Low-resolution images must be replaced with 
high-resolution images before flattening (that is, fatten before 
you flatten). If low-resolution images are flattened, the results 
will be low resolution.



Best Practices for Printers

•	Preseperated content (Photoshop DCS files)-InDesign CS3 can 
extract high resolution data from placed Photoshop DCS files, 
which can be flattened and output. This capability requires 
the DCS files not contain any vector data other than a clipping 
path. DCS files from other application should not be involved in 
transparency interactions.

•	Duotone, tritone, or quadtone images place-linked into legacy 
Illustrator files-While Illustrator CS2 and later handles these files 
properly, earlier versions of Illustrator do not.



Resources

•	Service Provider Search:
	 http://partners.adobe.com/asn/partnerfinder
•	Service Provider Resources:
	 http://www.adobe.com/studio/print/index.html
•	 A Designer’s Guide to Transparency for Print Output  
Using Adobe® Creative Suite 3 Software
This document provides detailed information about creating 
transparency effects and exporting and printing files that contain  
transparency.
•	Transparency in Adobe Applications: A Print Production 

Guide
This reference and troubleshooting guide for prepress providers  
contains detailed information about printing files with transparency.

http://partners.adobe.com/asn/partnerfinder



